Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
sincronizacion con opencart da error 404
#1
Hola!
he actualizado el sysme a la 5.02 y al intentar sincronizarlo contra un opencart nuevo al hacer el test me dice que ok pero luego no sincroniza nada y me sale un error 404. No se si me puede faltar algo por sincronizar o alguna cosa.

Saludos,
Spidey


Archivos adjuntos Miniatura(s)
       
Responder
#2
Buenas Spidey, el error 404 es "página no encontrada" ...dime el valor que tienes en el campo URL TIENDA para que lo compruebe
Oscar Guirado
Sysme Software

Sysme Software
Veravap
Responder
#3
Buenas,
La url que tiene es:
http://www.xn--elmono-araa-beb.com/shop
Responder
#4
Vale veo si trato de acceder a un fichero del módulo de Sysme Tpv, por ejemplo este http://www.xn--elmono-araa-beb.com/shop/.../token.php la web me dice que no lo encuentra .. también me cambia el formato de la url, ¿puedes confirmar en el hosting si los ficheros están?
Oscar Guirado
Sysme Software

Sysme Software
Veravap
Responder
#5
Buenas,
pues no tengo la carpeta sysmetpvoencart, en teoría se copia al darle a 'Instalar modulo', ¿no?
Responder
#6
Si, siempre que la ruta Opencart sea correcta ... si te dió el OK es que se subió, pero mira a ver donde
Oscar Guirado
Sysme Software

Sysme Software
Veravap
Responder
#7
no encuentro ninguna carpeta de sysme en el servidor. ¿Qué me recomiendas que haga?
Responder
#8
Conectate por FTP al servidor con los datos que le has dado a Sysme Tpv (el mismo usuario y misma contraseña), al entrar debes ver una carpeta public_html y dentro sysmetpvopencart .. ahi deben estar los ficheros porque Sysme Tpv ha dado el OK .. ahora bien, comprueba que esa carpeta (SYSMETPVOPENCART) está en el mismo directorio que la web, si no es así tendrás que volver a instalar el módulo pero en el directorio correcto.
Oscar Guirado
Sysme Software

Sysme Software
Veravap
Responder
#9
Buenas,
pues he mirado en el server y ni en /public_html/ ni en /public_html/shop tengo nada de SYSMETPVOPENCART. He vuelto a instalar el módulo y sigue sin crear nada.
Vale! era que la conexión ftp de tipo activa la rechazaba el servidor. La he puesto en pasiva y por fin me ha instalado la carpeta SYSMETPVOPENCART.

Ahora aparece abajo a la derecha el mensaje de que está sincronizando pero no veo que actualice nada y en el registro sale vacío tanto actualizados como pendientes. He marcado la casilla nueva de tienda en un producto y ahora lo sincroniza (te mando pantallazo). 
¿Hay alguna manera de no tener que hacerlo manualmente para los productos que ya tenían la marca de 'Sincronizar con Opencart' (eran miles)?


Archivos adjuntos Miniatura(s)
   
Responder
#10
Ok, primero activa la las categorías (esto ya lo puedes hacer a mano porque serán menos) para que se suban a la web.

Luego haz una copia de seguridad y luego ve a SISTEMA->MANTENIMIENTO->Pestaña CONSOLA DB para ejecutar estos 2 scripts (ejecutalos uno a uno):

delete from opencart_comg;
insert into opencart_comg (id_complementog,id_opencart) select id_complementog,"1" from complementog where sincopencart="Y" and cafeteria = "S";

Tras esto revisa que los productos están marcados para ser subidos a la web correcta.

Ya me dices.
Oscar Guirado
Sysme Software

Sysme Software
Veravap
Responder


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)

Contáctanos | Sysme Software | Volver arriba | | Archivo (Modo simple) | Sindicación RSS