Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
tpv imprime línea en blanco al abrir el cajón
#1
Hola.

Tengo un sysme tpv actualizado con una impresora Sewoo LK-T200 conectada por cable rj11 al cajón.

En el apartado de impresora tengo activo el "modo 2 de apertura" y el código para abrir el cajón tengo el 027\112\000\100\250\ del ejemplo, aunque he probado otros que encontré en este foro con el mismo resultado.

Tanto al pulsar Abrir Cajón como al totalizar un tíquet, al tiempo que se abre el cajón se envía un "retorno de carro" o se imprime una línea en blanco. Si imprimo el tíquet, el espacio de cabecera es excesivo y si no lo imprimo, cada vez que abro el cajón me va sacando papel.

¿Alguna solución para este problema?

Un saludo y gracias.
Responder
#2
Buenas karlggest,

Muchas impresoras tienen los drivers configurados por defecto para que hagan un feed de papel al lanzar la impresión, debes reducir (o eliminar) esto en las opciones avanzadas del driver de la impresora en el panel de control de Windows.

Ya me dices.
Oscar Guirado
Sysme Software

Sysme Software
Sysme Pos Software
Oscar Online
Responder
#3
Hola.

Sigue desplazando papel al abrir el cajón.
(10-08-2017, 10:51 PM)sysme escribió: Buenas karlggest,

Muchas impresoras tienen los drivers configurados por defecto para que hagan un feed de papel al lanzar la impresión, debes reducir (o eliminar) esto en las opciones avanzadas del driver de la impresora en el panel de control de Windows.

Ya me dices.
En la Opciones Avanzadas->Valores de Impresión hay una pestaña llamada "print commands"; en ellos tenía seleccionadas un par de opciones: Tanto en Begin Document como en End Document, tenía seleccionado "open cash drawer: 150ms". He deseleccionado eso y no tengo ninguna opción más.

En "End Document" hay una que permite poner líneas en blanco pero tiene valor 0 (admite valores 0-99).

No veo ninguna opción que parezca relacionada.

¿Alguna idea?

Gracias por la ayuda.
Responder
#4
Vamos a comprobar que no sea problema de la secuencia ... prueba el modo 1 de apertura (con la secuencia con el formato del modo 1), a ver si así también imprime la linea en blanco.
Oscar Guirado
Sysme Software

Sysme Software
Sysme Pos Software
Oscar Online
Responder
#5
(20-08-2017, 08:10 PM)sysme escribió: Vamos a comprobar que no sea problema de la secuencia ... prueba el modo 1 de apertura (con la secuencia con el formato del modo 1), a ver si así también imprime la linea en blanco.
Hola.

¿A qué te refieres con la secuencia de formato 1? He activado el modo 1 de apertura pero dejando la misma configuración en "impresora" y hace lo mismo.

La secuencia es la que pone en la pantalla a modo de ejemplo.

Salud y gracias por la ayuda.
Responder
#6
He encontrado el manual de el modelo de la impresora, pero no especifica cual es el comando correcto para la apertura ... no se que decirte.
Oscar Guirado
Sysme Software

Sysme Software
Sysme Pos Software
Oscar Online
Responder
#7
Hola.
(21-08-2017, 08:54 PM)sysme escribió: He encontrado el manual de el modelo de la impresora, pero no especifica cual es el comando correcto para la apertura ... no se que decirte.

Puedes pasarme el enlace a ver si trae algo que pueda servirme?

Salud!!
Responder
#8
Aquí tienes: https://www.manualslib.com/manual/931307...tml#manual
Oscar Guirado
Sysme Software

Sysme Software
Sysme Pos Software
Oscar Online
Responder


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)

Contáctanos | Sysme Software | Volver arriba | | Archivo (Modo simple) | Sindicación RSS